CRON_JOB not installed

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

CRON_JOB not installed

Christoph Litauer
Dear thinstation users,

I configured some cronjobs for my thinstations in a group configuration file (thinstation.conf.group-auth):
CRON_JOB1='30 22 * * Mon-Thu /bin/shutdown -h now'
CRON_JOB2='30 20 * * Fri /bin/shutdown -h now'
CRON_JOB3='30 15 * * Sat /bin/shutdown -h now'
CRON_JOB4='30 08 * * Sun /bin/shutdown -h now'

The client loads the configuration file but does not add the configured jobs to crontab. When executing "/etc/init.d/crond init" everything is fine. Seems as if the init for crond is not done while booting. /etc/rc2.d/S08crond is linked to /etc/init.d/crond.

Any ideas?

--
Kind regards
Christoph
_________________________________________
Christoph Litauer
Uni Koblenz, Computing Centre, Office A 022    
Postfach 201602, 56016 Koblenz    
Fon: +49 261 287-1311, Fax: -100 1311





------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: CRON_JOB not installed

Don Cupp
The init from cron is running before network files, so the cron jobs are not being added. You can rename the link in

packages/base/etc/rc2.d/S08cron to S20cron


On Saturday, January 24, 2015 8:36 AM, Christoph Litauer <[hidden email]> wrote:


Dear thinstation users,

I configured some cronjobs for my thinstations in a group configuration file (thinstation.conf.group-auth):
CRON_JOB1='30 22 * * Mon-Thu /bin/shutdown -h now'
CRON_JOB2='30 20 * * Fri /bin/shutdown -h now'
CRON_JOB3='30 15 * * Sat /bin/shutdown -h now'
CRON_JOB4='30 08 * * Sun /bin/shutdown -h now'

The client loads the configuration file but does not add the configured jobs to crontab. When executing "/etc/init.d/crond init" everything is fine. Seems as if the init for crond is not done while booting. /etc/rc2.d/S08crond is linked to /etc/init.d/crond.

Any ideas?

--
Kind regards
Christoph
_________________________________________
Christoph Litauer
Uni Koblenz, Computing Centre, Office A 022   
Postfach 201602, 56016 Koblenz   
Fon: +49 261 287-1311, Fax: -100 1311





------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general



------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Udo
Reply | Threaded
Open this post in threaded view
|

Re: CRON_JOB not installed

Udo
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: CRON_JOB not installed

Christoph Litauer
I never had that problem with 5.2 and 6.0b. Started with 5.3.
But Dons solution did it, thank you Don!

> Am 26.01.2015 um 11:35 schrieb Udo <[hidden email]>:
>
> Don Cupp <doncuppjr@...> writes:
>
>>
>>
>> The init from cron is running before network files, so the cron jobs are
> not being added. You can rename the link in
>>
>> packages/base/etc/rc2.d/S08cron to S20cron
>>
>>
>>     On Saturday, January 24, 2015 8:36 AM, Christoph Litauer <litauer
> <at> uni-koblenz.de> wrote:
>
>
> .... hmmmm.
>
> Did it at TS 5.1 with
>
> CRON_JOB1="00 21 * * 2,4 /sbin/poweroff"
> CRON_JOB2="00 21 * * 1,3,5,6,0 /sbin/poweroff"
>
> at thinstation.conf.network, and it works fine witout renaming anything.
>
> crontab -l at the client shows it as expexted.
>
> What could be the difference that makes it working at my stations?
>

--
Kind regards
Christoph
_________________________________________
Christoph Litauer
Uni Koblenz, Computing Centre, Office A 022    
Postfach 201602, 56016 Koblenz    
Fon: +49 261 287-1311, Fax: -100 1311





------------------------------------------------------------------------------
Dive into the World of Parallel Programming. The Go Parallel Website,
sponsored by Intel and developed in partnership with Slashdot Media, is your
hub for all things parallel software development, from weekly thought
leadership blogs to news, videos, case studies, tutorials and more. Take a
look and join the conversation now. http://goparallel.sourceforge.net/
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: CRON_JOB not installed

chickenwalker
In reply to this post by Don Cupp
Don Cupp wrote
The init from cron is running before network files, so the cron jobs are not being added. You can rename the link in
packages/base/etc/rc2.d/S08cron to S20cron
I'm having this same issue in 5.5.1. How do I fix it in that release?
Reply | Threaded
Open this post in threaded view
|

Re: CRON_JOB not installed

chickenwalker
chickenwalker wrote
Don Cupp wrote
The init from cron is running before network files, so the cron jobs are not being added. You can rename the link in
packages/base/etc/rc2.d/S08cron to S20cron
I'm having this same issue in 5.5.1. How do I fix it in that release?
Nevermind, I got it working. Sample CRON_JOB has /bin/poweroff should be /sbin/poweroff.
Reply | Threaded
Open this post in threaded view
|

Re: CRON_JOB not installed

thinstation-general mailing list
In reply to this post by chickenwalker
Same fix


Sent from Yahoo Mail for iPhone

On Friday, June 9, 2017, 9:05 AM, chickenwalker <[hidden email]> wrote:

Don Cupp wrote
> The init from cron is running before network files, so the cron jobs are
> not being added. You can rename the link in
> packages/base/etc/rc2.d/S08cron to S20cron

I'm having this same issue in 5.5.1. How do I fix it in that release?




--
Sent from the thinstation-general mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Thinstation-general mailing list

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general