Citrix Receiver 13: selfservice causes errors on connect to Store

classic Classic list List threaded Threaded
16 messages Options
Udo
Reply | Threaded
Open this post in threaded view
|

Citrix Receiver 13: selfservice causes errors on connect to Store

Udo
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Citrix Receiver 13: selfservice causes errors on connect to Store

Don Cupp
Cd to the root of the cloned directory.
rm -rf *
git checkout -f
./setup-chroot


Sent from my Verizon Wireless 4G LTE smartphone


-------- Original message --------
From: Udo <[hidden email]>
Date: 01/12/2015 2:41 AM (GMT-08:00)
To: [hidden email]
Subject: [Thinstation-general] Citrix Receiver 13: selfservice causes errors on connect to Store

Hi.

Using TS 5.3 with Citrix Reciever 13.1 I call "selfservice" to connect to a
Storefront server on a Xen Desktop 7 Site.

So this works basically, selfservice states a trusted conenction and the
login at the server is also successfull.
But at the buttons of the login prompt there is a strange flickering a few
millimeters to the left and the right. So there seems to be another problem.

But the main problem is, unlike at my debian station, selfservice aborts
with errors.

After succesfull login, ica_wfc fails with error, in detail this
shows:

Running fullscreen ica_wfc
**Message: console message:
file:///opt/Citrix/ICAClient/site/scripts/Default.htm.style.min.js
@1:Tracing disabled

This is followed by a couple of messages like:
GdkPixbuf-CRITICAL **.gdk_pixbuf_get_width: assertion `GDK_IS_PIXBUF
(pixbuf)`failed

Hoping for a hint, with thanks in advance

Udo



------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
vanity: www.gigenet.com
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general

------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
vanity: www.gigenet.com
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Udo
Reply | Threaded
Open this post in threaded view
|

Re: Citrix Receiver 13: selfservice causes errors on connect to Store

Udo
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Citrix Receiver 13: selfservice causes errors on connect to Store

Don Cupp
cd /build
cp conf/default/* .

Other than that, just delete the uncompressed archive folder, and expand it again.


On Tuesday, January 13, 2015 1:46 AM, Udo <[hidden email]> wrote:


Donald A. Cupp Jr. <[hidden email]> writes:

>
>
> Cd to the root of the cloned directory.
> rm -rf *
> git checkout -f
> ./setup-chroot
>
>
> Sent from my Verizon Wireless 4G LTE smartphone
>
> -------- Original message --------From: Udo <udo.buechner <at> wartburg-
sparkasse.de> Date: 01/12/2015  2:41 AM  (GMT-08:00) To: thinstation-
general <at> lists.sourceforge.net Subject: [Thinstation-general] Citrix
Receiver 13: selfservice causes errors

Don,

I am not quite sure what You mean with "cloned directory".
The root of my build environment, from where I usually call ./setup-chroot?
So, Your hint to rm it would delete the whole tree ...?

And, I cannot use the git repository here because we are behind a proxy of
our servicepartner, and this proxy sometimes makes trouble.
So I downloaded the tar (Thinstation-thinstation-v5.3.1-0-g5e29ceb.tar.gz)
and used this for building TS.

How to handle Your hint at this environment?
*confused*

Rgds.

Udo




------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general



------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Udo
Reply | Threaded
Open this post in threaded view
|

Re: Citrix Receiver 13: selfservice causes errors on connect to Store

Udo
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Citrix Receiver 13: selfservice causes errors on connect to Store

Don Cupp
Which cursor are you using?


On Monday, January 19, 2015 6:05 AM, Udo <[hidden email]> wrote:


Don Cupp <[hidden email]> writes:

> cd /build
> cp conf/default/* .
>
> Other than that, just delete the uncompressed archive folder, and expand
it again.
>      On Tuesday, January 13, 2015 1:46 AM, Udo <udo.buechner-
EcGxh6KpiiYvEn/[hidden email]> wrote:  Donald A. Cupp
Jr. <doncuppjr <at> ...> writes:> > > Cd to the root of the cloned
directory.> rm -rf *> git checkout -f> ./setup-chroot> > > Sent from my
Verizon Wireless 4G LTE smartphone> > -------- Original message --------
From: Udo <udo.buechner <at> wartburg-sparkasse.de> Date: 01/12/2015  2:41
AM  (GMT-08:00) To: thinstation-general <at> lists.sourceforge.net Subject:
[Thinstation-general] Citrix Receiver 13: selfservice causes errors

Don,

I extracted the tar file again and tried it again with this new created
environment.
The problems still remain the same:

- The buttons of the login prompt window are strange flickering a few
millimeters to the left and the right. Nevertheless it is possible to enter
user credentials.
(The flickering also happened before, when the EULA window popped up.
Accepting here also was possible.)

- The main problem still is: selfservice aborts with errors. After
succesfull login, ica_wfc fails with error, in detail this shows (as I
described before):

---------------------------
Running fullscreen ica_wfc
**Message: console message:
file:///opt/Citrix/ICAClient/site/scripts/Default.htm.style.min.js
<at> 1:Tracing disabled

This is followed by a couple of messages from "selfservice" like:
GdkPixbuf-CRITICAL **.gdk_pixbuf_get_width: assertion `GDK_IS_PIXBUF
(pixbuf)`failed
---------------------------

Using a browser I can successfull connect to Citrix StoreWeb.

Any idea .... ?

Best regards,

Udo
------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general



------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Udo
Reply | Threaded
Open this post in threaded view
|

Re: Citrix Receiver 13: selfservice causes errors on connect to Store

Udo
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Citrix Receiver 13: selfservice causes errors on connect to Store

Don Cupp
You do not need to use the
X_DEVICE_OPTION1="swcursor On"

For a hardware cursor, comment out

#package icons-cursor

For a nice software cursor, uncomment

package icons-cursor

That is all that is required to choose between the two.
On another note, icewm is quite old. Have you tried this with xfwm?


On Monday, January 19, 2015 11:52 PM, Udo <[hidden email]> wrote:


Don Cupp <[hidden email]> writes:

>
>
> Which cursor are you using?
>
>

... I use ICEWM and tried with different themes.
Current ICEWM_THEME is "motif".

I don't know how to change the cursor. The only options I found are

X_DEVICE_OPTION1="swcursor On"

at thinstation.conf.buildtime and

vt.global_cursor_default=0

at syslinux.cfg.

Which setting are You talking about and where should I search for it?

Rgds.

Udo


------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general



------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Udo
Reply | Threaded
Open this post in threaded view
|

Re: Citrix Receiver 13: selfservice causes errors on connect to Store

Udo
CONTENTS DELETED
The author has deleted this message.
Udo
Reply | Threaded
Open this post in threaded view
|

Re: CitrixReceiver 13: selfservice causes errors on connect to Store

Udo
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: CitrixReceiver 13: selfservice causes errors on connect to Store

Michael K-2
One thing that comes to mind.
When using icewm and openbox, I'm not sure any icon sets get included, like icons-hicolor.
Likewise with gtk-2.0
If you've built a very tiny image, you might not have included something that selfservice wants. The new version moved from Motif to GTK, so maybe there's a dependency that hasn't been accounted for.
When using openbox, did you or have comment out gtk-2.0 and icons-hicolor and icons-gnome in build.conf?  Maybe add them back in?

On Wed, Jan 21, 2015 at 12:18 PM, Udo <[hidden email]> wrote:
Udo <udo.buechner@...> writes:

> Hello Don,
>
> ICEWM I used only for testing. So I switched to openbox (which is
> designated for the future use of TS) and also uncommented package icons-
> cursor. The flickering now does not occur anymore.
>
> But the error with "tracking disabled" and the following GDK-pixbuf-
errors
> from selfservice are still remaining ....
>
> Rgds.
>
> Udo


... meanwhile I tried it with Your default configuration (I added package
ica )using xfce.

TS connects without any error to the Citrix Site.
Any idea what causes the problems with openbox?

To mak sure there is no problem with other parts of my configuration I will
make another try using my config files but switching to xfce.

Could You please state, which are the neccessary parts of the xfce
configuration? I thought this should be sufficient:

build.conf:

package xfce

thinstation.conf.buildtime:

SESSION_0_TYPE=xfwm4
SESSION_0_AUTOSTART=on
XFWM4_COMPOSITING=true
XFWM4_BRIGHTNESS="-33"
XFWM4_RED=0
XFWM4_GREEN=0
XFWM4_BLUE=0
XFWM4_START_POSITION="BOTTOM"
DESKTOP_ICON_SIZE=48
DESKTOP_FONT_SIZE=8
GTK_THEME=Xfce
XFWM4_THEME=Default

Rgds.

Udo




------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general


------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: CitrixReceiver 13: selfservice causes errors on connect to Store

Don Cupp
In reply to this post by Udo
They only thing that comes to mind now, is that neither openbox or icewm have compositing, while xfwm does. The new ICA self service portal is based on webkit, which is quite an extensive and high level API. It may very well require compositing, or the makers of the portal didn't know how to make it not want compositing.(total theory blown out my @$$)

Anyways, xfwm is a very popular / well maintained window manager, and that is why it was selected as the successor to icewm in Thinstation.


On Wednesday, January 21, 2015 3:19 AM, Udo <[hidden email]> wrote:


Udo <[hidden email]> writes:

> Hello Don,
>
> ICEWM I used only for testing. So I switched to openbox (which is
> designated for the future use of TS) and also uncommented package icons-
> cursor. The flickering now does not occur anymore.
>
> But the error with "tracking disabled" and the following GDK-pixbuf-
errors
> from selfservice are still remaining ....
>
> Rgds.
>
> Udo


... meanwhile I tried it with Your default configuration (I added package
ica )using xfce.

TS connects without any error to the Citrix Site.
Any idea what causes the problems with openbox?

To mak sure there is no problem with other parts of my configuration I will
make another try using my config files but switching to xfce.

Could You please state, which are the neccessary parts of the xfce
configuration? I thought this should be sufficient:

build.conf:

package xfce

thinstation.conf.buildtime:

SESSION_0_TYPE=xfwm4
SESSION_0_AUTOSTART=on
XFWM4_COMPOSITING=true
XFWM4_BRIGHTNESS="-33"
XFWM4_RED=0
XFWM4_GREEN=0
XFWM4_BLUE=0
XFWM4_START_POSITION="BOTTOM"
DESKTOP_ICON_SIZE=48
DESKTOP_FONT_SIZE=8
GTK_THEME=Xfce
XFWM4_THEME=Default

Rgds.

Udo




------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general



------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: CitrixReceiver 13: selfservice causes errors on connect to Store

Michael K-2
Citrix crashes as described when the gtk-2.0 package is not included.
I think it's because that package has the pixbufloader modules.

Udo - you need to add gtk-2.0 in ica/dependencies or add gtk-2.0 in your build.conf when using openbox.

Also, I confirmed the flickering login/EULA in icewm but haven't pursued a solution (and probably will not).

On Wed, Jan 21, 2015 at 3:39 PM, Don Cupp <[hidden email]> wrote:
They only thing that comes to mind now, is that neither openbox or icewm have compositing, while xfwm does. The new ICA self service portal is based on webkit, which is quite an extensive and high level API. It may very well require compositing, or the makers of the portal didn't know how to make it not want compositing.(total theory blown out my @$$)

Anyways, xfwm is a very popular / well maintained window manager, and that is why it was selected as the successor to icewm in Thinstation.


On Wednesday, January 21, 2015 3:19 AM, Udo <[hidden email]> wrote:


Udo <[hidden email]> writes:

> Hello Don,
>
> ICEWM I used only for testing. So I switched to openbox (which is
> designated for the future use of TS) and also uncommented package icons-
> cursor. The flickering now does not occur anymore.
>
> But the error with "tracking disabled" and the following GDK-pixbuf-
errors
> from selfservice are still remaining ....
>
> Rgds.
>
> Udo


... meanwhile I tried it with Your default configuration (I added package
ica )using xfce.

TS connects without any error to the Citrix Site.
Any idea what causes the problems with openbox?

To mak sure there is no problem with other parts of my configuration I will
make another try using my config files but switching to xfce.

Could You please state, which are the neccessary parts of the xfce
configuration? I thought this should be sufficient:

build.conf:

package xfce

thinstation.conf.buildtime:

SESSION_0_TYPE=xfwm4
SESSION_0_AUTOSTART=on
XFWM4_COMPOSITING=true
XFWM4_BRIGHTNESS="-33"
XFWM4_RED=0
XFWM4_GREEN=0
XFWM4_BLUE=0
XFWM4_START_POSITION="BOTTOM"
DESKTOP_ICON_SIZE=48
DESKTOP_FONT_SIZE=8
GTK_THEME=Xfce
XFWM4_THEME=Default

Rgds.

Udo




------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general



------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general



------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Udo
Reply | Threaded
Open this post in threaded view
|

Re: CitrixReceiver 13: selfservice causes errors on connect to Store

Udo
In reply to this post by Michael K-2
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: CitrixReceiver 13: selfservice causes errors on connect to Store

Michael K-2
Create an ica SESSION with the SERVER set to https://whatever, where whatever is the full path as shown in the connection manager.

Example:
SESSION_1_TYPE=ica
SESSION_1_TITLE="Citrix Stuff"
SESSION_1_ICON=off



On Thu, Jan 22, 2015 at 11:56 AM, Udo <[hidden email]> wrote:
Michael K <ts.michaelk@...> writes:

>
>
> One thing that comes to mind.When using icewm and openbox, I'm not sure
any icon sets get included, like icons-hicolor.
> Likewise with gtk-2.0
> If you've built a very tiny image, you might not have included something
that selfservice wants. The new version moved from Motif to GTK, so maybe
there's a dependency that hasn't been accounted for.
> When using openbox, did you or have comment out gtk-2.0 and icons-hicolor
and icons-gnome in build.conf?  Maybe add them back in?
>
>

Michael, Don,

thanks for Your hints. I got it working adding package gtk-2.0.
(The icon packages are apparently not needed.)
No flickering, no errors connecting to the citrix site.

That was a big step. Now the client basically works. So thanks again.

Now I can play the ball over to our citrix guys, to make the applications
at the new site working.

But there is just one thing: it needs a preconfiguration at TS.

The minimum just would be to avoid the input of the servername for
selfservice, which is actually still needed.
(May be all other configuration is possible by central configuration of the
citrix site ...

If You have any idea regarding this, please drop me a line.

Best Regards,

Udo


------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general


------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Udo
Reply | Threaded
Open this post in threaded view
|

Re: CitrixReceiver 13: selfservice causes errors on connect to Store

Udo
CONTENTS DELETED
The author has deleted this message.