Problem with ICA sessions with Thinstation 5.2

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with ICA sessions with Thinstation 5.2

Stefano Ceccherini
Hi!
It seems there is a regression with ICA sessions with the latest Thinstation 5.2.

On the testing machine, on startup, I get a "The connection to Desktop was lost" (Desktop is the name of the ICA published application I'm autostarting) "An attempt to reconnect will start in 30 seconds". After a minute (two connection attempts later), the Desktop starts correctly.
I havent' tried on other machines yet.Anyone had similar problems ?


This is the thinstation.conf.network I'm using:

# Global options
DAILY_REBOOT=On # reboot once a day if no active sessions
RECONNECT_PROMPT=MENU30 # Show a menu "reconnect - shutdown" with a timeout of 30 minutes
USB_ENABLED=On
USB_STORAGE_SYNC=On
USB_MOUNT_USELABEL=Yes
NET_TIME_SERVER=192.168.22.9
TIME_ZONE="CET-1CEST,M3.5.0,M10.5.0/3"
AUDIO_LEVEL=70

# Global ICA options
ICA_BROWSER_PROTOCOL=HTTPonTCP
ICA_USE_SERVER_KEYBOARD=On
ICA_ENCRYPTION=Basic
ICA_COMPRESS=On
ICA_AUDIO=On
#ICA_SMARTCARD=Off
ICA_AUDIO_QUALITY=Medium
ICA_PRINTER=Off
ICA_SEAMLESS_WINDOW=Off


# Client Drives
ICA_WFCLIENT_CLIENTDRIVE=On
ICA_WFCLIENT_DrivePathF=/mnt/usbdevice
ICA_WFCLIENT_DriveEnabledF=On
ICA_WFCLIENT_DriveReadAccessF=0
ICA_WFCLIENT_DriveWriteAccessF=0

# X server options
SCREEN_RESOLUTION="1280x1024|1024x768|800x600|*"
SCREEN_COLOR_DEPTH="24|16"
#X_DRIVER_OPTION3="noDDC Off"

# Sessions
SESSION_0_TYPE=ica
SESSION_0_AUTOSTART=on
SESSION_0_ICA_APPLICATION_SET="Desktop"
SESSION_0_ICA_APPSRV_DISABLECTRLALTDEL=On
SESSION_0_ICA_AUDIO=On


------------------------------------------------------------------------------
"Accelerate Dev Cycles with Automated Cross-Browser Testing - For FREE
Instantly run your Selenium tests across 300+ browser/OS combos.
Get unparalleled scalability from the best Selenium testing platform available
Simple to use. Nothing to install. Get started now for free."
http://p.sf.net/sfu/SauceLabs
_______________________________________________
Thinstation-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-developer
Reply | Threaded
Open this post in threaded view
|

Re: Problem with ICA sessions with Thinstation 5.2

Michael K-2
What happens when you start a window manager on session 0 and ICA on session 1?  Or start an xterm on 0 or 1 so you can view the logs /var/run/applications/ica.*
Did you blank out the server for security reasons, or does ICA have a magic approach to finding the server?

- Michael


On Wed, May 21, 2014 at 1:05 AM, Stefano Ceccherini <[hidden email]> wrote:
Hi!
It seems there is a regression with ICA sessions with the latest Thinstation 5.2.

On the testing machine, on startup, I get a "The connection to Desktop was lost" (Desktop is the name of the ICA published application I'm autostarting) "An attempt to reconnect will start in 30 seconds". After a minute (two connection attempts later), the Desktop starts correctly.
I havent' tried on other machines yet.Anyone had similar problems ?


This is the thinstation.conf.network I'm using:

# Global options
DAILY_REBOOT=On # reboot once a day if no active sessions
RECONNECT_PROMPT=MENU30 # Show a menu "reconnect - shutdown" with a timeout of 30 minutes
USB_ENABLED=On
USB_STORAGE_SYNC=On
USB_MOUNT_USELABEL=Yes
NET_TIME_SERVER=192.168.22.9
TIME_ZONE="CET-1CEST,M3.5.0,M10.5.0/3"
AUDIO_LEVEL=70

# Global ICA options
ICA_BROWSER_PROTOCOL=HTTPonTCP
ICA_USE_SERVER_KEYBOARD=On
ICA_ENCRYPTION=Basic
ICA_COMPRESS=On
ICA_AUDIO=On
#ICA_SMARTCARD=Off
ICA_AUDIO_QUALITY=Medium
ICA_PRINTER=Off
ICA_SEAMLESS_WINDOW=Off


# Client Drives
ICA_WFCLIENT_CLIENTDRIVE=On
ICA_WFCLIENT_DrivePathF=/mnt/usbdevice
ICA_WFCLIENT_DriveEnabledF=On
ICA_WFCLIENT_DriveReadAccessF=0
ICA_WFCLIENT_DriveWriteAccessF=0

# X server options
SCREEN_RESOLUTION="1280x1024|1024x768|800x600|*"
SCREEN_COLOR_DEPTH="24|16"
#X_DRIVER_OPTION3="noDDC Off"

# Sessions
SESSION_0_TYPE=ica
SESSION_0_AUTOSTART=on
SESSION_0_ICA_APPLICATION_SET="Desktop"
SESSION_0_ICA_APPSRV_DISABLECTRLALTDEL=On
SESSION_0_ICA_AUDIO=On


------------------------------------------------------------------------------
"Accelerate Dev Cycles with Automated Cross-Browser Testing - For FREE
Instantly run your Selenium tests across 300+ browser/OS combos.
Get unparalleled scalability from the best Selenium testing platform available
Simple to use. Nothing to install. Get started now for free."
http://p.sf.net/sfu/SauceLabs
_______________________________________________
Thinstation-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-developer



------------------------------------------------------------------------------
"Accelerate Dev Cycles with Automated Cross-Browser Testing - For FREE
Instantly run your Selenium tests across 300+ browser/OS combos.
Get unparalleled scalability from the best Selenium testing platform available
Simple to use. Nothing to install. Get started now for free."
http://p.sf.net/sfu/SauceLabs
_______________________________________________
Thinstation-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-developer
Reply | Threaded
Open this post in threaded view
|

Re: Problem with ICA sessions with Thinstation 5.2

rdesbois
Hi !

Personally
I am using /opt/Citrix/ICA Client/util/storebrowse instead of wfica
since receiver v13.
Its configuration is very simple and very reliable.
You just must spend a little time to change Thinstation's scripts.


Stef



Le 21/05/2014 16:12, Michael K a écrit :
What happens when you start a window manager on session 0 and ICA on session 1?  Or start an xterm on 0 or 1 so you can view the logs /var/run/applications/ica.*
Did you blank out the server for security reasons, or does ICA have a magic approach to finding the server?

- Michael


On Wed, May 21, 2014 at 1:05 AM, Stefano Ceccherini <[hidden email]> wrote:
Hi!
It seems there is a regression with ICA sessions with the latest Thinstation 5.2.

On the testing machine, on startup, I get a "The connection to Desktop was lost" (Desktop is the name of the ICA published application I'm autostarting) "An attempt to reconnect will start in 30 seconds". After a minute (two connection attempts later), the Desktop starts correctly.
I havent' tried on other machines yet.Anyone had similar problems ?


This is the thinstation.conf.network I'm using:

# Global options
DAILY_REBOOT=On # reboot once a day if no active sessions
RECONNECT_PROMPT=MENU30 # Show a menu "reconnect - shutdown" with a timeout of 30 minutes
USB_ENABLED=On
USB_STORAGE_SYNC=On
USB_MOUNT_USELABEL=Yes
NET_TIME_SERVER=192.168.22.9
TIME_ZONE="CET-1CEST,M3.5.0,M10.5.0/3"
AUDIO_LEVEL=70

# Global ICA options
ICA_BROWSER_PROTOCOL=HTTPonTCP
ICA_USE_SERVER_KEYBOARD=On
ICA_ENCRYPTION=Basic
ICA_COMPRESS=On
ICA_AUDIO=On
#ICA_SMARTCARD=Off
ICA_AUDIO_QUALITY=Medium
ICA_PRINTER=Off
ICA_SEAMLESS_WINDOW=Off


# Client Drives
ICA_WFCLIENT_CLIENTDRIVE=On
ICA_WFCLIENT_DrivePathF=/mnt/usbdevice
ICA_WFCLIENT_DriveEnabledF=On
ICA_WFCLIENT_DriveReadAccessF=0
ICA_WFCLIENT_DriveWriteAccessF=0

# X server options
SCREEN_RESOLUTION="1280x1024|1024x768|800x600|*"
SCREEN_COLOR_DEPTH="24|16"
#X_DRIVER_OPTION3="noDDC Off"

# Sessions
SESSION_0_TYPE=ica
SESSION_0_AUTOSTART=on
SESSION_0_ICA_APPLICATION_SET="Desktop"
SESSION_0_ICA_APPSRV_DISABLECTRLALTDEL=On
SESSION_0_ICA_AUDIO=On


------------------------------------------------------------------------------
"Accelerate Dev Cycles with Automated Cross-Browser Testing - For FREE
Instantly run your Selenium tests across 300+ browser/OS combos.
Get unparalleled scalability from the best Selenium testing platform available
Simple to use. Nothing to install. Get started now for free."
http://p.sf.net/sfu/SauceLabs
_______________________________________________
Thinstation-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-developer




------------------------------------------------------------------------------
"Accelerate Dev Cycles with Automated Cross-Browser Testing - For FREE
Instantly run your Selenium tests across 300+ browser/OS combos.
Get unparalleled scalability from the best Selenium testing platform available
Simple to use. Nothing to install. Get started now for free."
http://p.sf.net/sfu/SauceLabs


_______________________________________________
Thinstation-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-developer


------------------------------------------------------------------------------
"Accelerate Dev Cycles with Automated Cross-Browser Testing - For FREE
Instantly run your Selenium tests across 300+ browser/OS combos.
Get unparalleled scalability from the best Selenium testing platform available
Simple to use. Nothing to install. Get started now for free."
http://p.sf.net/sfu/SauceLabs
_______________________________________________
Thinstation-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-developer