TS5.4 blockdev error

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

TS5.4 blockdev error

Humulus
Hi Don,

I've created an installer script to install our Thinstation image to
harddisk (used your installer package as an example).
This was working fine with Thinstation 5.3, but in TS 5.4 is a newer
Util-linux package that has the "Failed to read partition start from sysfs"
error (see https://bugzilla.redhat.com/show_bug.cgi?id=1202443).

How can I change the util-linux package to a version without this error?

regards,

Ruud


------------------------------------------------------------------------------
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: TS5.4 blockdev error

Don Cupp
I think you only need to pull, as I upgraded past that error in master and stable. What version does prt-get info util-linux return?



On Monday, September 14, 2015 7:18 AM, Ruud Hop <[hidden email]> wrote:


Hi Don,

I've created an installer script to install our Thinstation image to
harddisk (used your installer package as an example).
This was working fine with Thinstation 5.3, but in TS 5.4 is a newer
Util-linux package that has the "Failed to read partition start from sysfs"
error (see https://bugzilla.redhat.com/show_bug.cgi?id=1202443).

How can I change the util-linux package to a version without this error?

regards,

Ruud


------------------------------------------------------------------------------
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general



------------------------------------------------------------------------------

_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: TS5.4 blockdev error

Humulus
Don Cupp <doncuppjr@...> writes:

>
> I think you only need to pull, as I upgraded past that error in master and
stable. What version does prt-get info util-linux return?  
>

Name:         util-linux
Path:         /ts/ports/core
Version:      2.26.1
Release:      1
Description:  Miscellaneous system utilities
URL:          http://userweb.kernel.org/~kzak/util-linux-ng/
Maintainer:   CRUX System Team, core-ports at crux dot nu
Dependencies: ncurses,zlib

regards,
Ruud


------------------------------------------------------------------------------
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: TS5.4 blockdev error

Humulus
In reply to this post by Don Cupp
Don Cupp <doncuppjr@...> writes:

>
>
> I think you only need to pull,

Did a git pull. Got a newer version of util-linux: 2.26.2.
But after ./build my iso image is 20MB smaller then before the git pull.
When I try to boot this image I get a kernel panic: no working init found.




------------------------------------------------------------------------------
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: TS5.4 blockdev error

FredGreg
Hi.

I simply copied blockdev(usr/sbin) from this archive(http://rpmfind.net//linux/RPM/opensuse/factory/i586/util-linux-2.26.2-3.1.i586.html) and replaced the binary in packages/util-linux/sbin/blockdev.

This got rid of the error.






Reply | Threaded
Open this post in threaded view
|

Re: TS5.4 blockdev error

Humulus
FredGreg <fredgreg28@...> writes:

>
> Hi.
>
> I simply copied blockdev(usr/sbin) from this
>
archive(http://rpmfind.net//linux/RPM/opensuse/factory/i586/util-linux-2.26.2-3.1.i586.html)
> and replaced the binary in packages/util-linux/sbin/blockdev.
>
> This got rid of the error.
>

Glad I made a copy of the build environment before the git pull :-)
This blockdev works.

Thanks,
Ruud




------------------------------------------------------------------------------
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: TS5.4 blockdev error

Don Cupp
that was updated a while back, so not sure what all has changed since then.



On Friday, September 18, 2015 7:55 AM, Ruud Hop <[hidden email]> wrote:


FredGreg <[hidden email]> writes:

>
> Hi.
>
> I simply copied blockdev(usr/sbin) from this
>
archive(http://rpmfind.net//linux/RPM/opensuse/factory/i586/util-linux-2.26.2-3.1.i586.html)
> and replaced the binary in packages/util-linux/sbin/blockdev.
>
> This got rid of the error.
>

Glad I made a copy of the build environment before the git pull :-)
This blockdev works.

Thanks,
Ruud




------------------------------------------------------------------------------
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general



------------------------------------------------------------------------------

_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general