Thinstation on Old Hardware

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Thinstation on Old Hardware

Flavio Silva
Hi People!

I'm trying to build a Thinstation image to run on old hardware (AMD
Geode 266).
I've seen that the option ./build --kernel UP, should get and use a
kernel that doesn't have the PAE extension, but apears to be using some
virtualization extension. I've tested that and each time it boots, i got
a kernel panic.
This happens to the actual version, the TS 5.4.2, and the older version,
TS 5.1.2.

I've tested the images on the following hardwares:
     - AMD Geode 266;
     - AMD K6-2 266;
     - (Test Environment) VirtualBox with PAE and Virtualizations
Extensions disabled.

How i can build a image to work the Geode Hardware ?
If there is any way to rebuild the kernel, i'm looking to try.
There is any guidance on building a new kernel for thinstation ?

Thanks for all!!
Flávio Silva

------------------------------------------------------------------------------
Don't Limit Your Business. Reach for the Cloud.
GigeNET's Cloud Solutions provide you with the tools and support that
you need to offload your IT needs and focus on growing your business.
Configured For All Businesses. Start Your Cloud Today.
https://www.gigenetcloud.com/
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: Thinstation on Old Hardware

Alon
Hi, Im also running TS 5.4 on Amd geode with ./build --kernel UP with no problems.
Are you sure its related to Non Pae kernel?
Reply | Threaded
Open this post in threaded view
|

Re: Thinstation on Old Hardware

Flavio Silva
Hi Alon!

Thanks. You are right!
It's not only related to the PAE.
The fact is that the AMD Geode that i'm using doesn't have the PAE, and
AMD-V.
I've disabled that one in the VirtualBox too, and reproduced the problem.

If someone is willing to reproduce or help work on that, the virtualized
machine (using VirtualBox) is:
     - 32Bits
     - No PAE, VT-x/AMD-V
     - No Harddisk
     - Chipset PIIX3

I appreciate any help on this.

Thanks,
Flávio Silva

On 15/07/2015 14:17, Alon wrote:

> Hi, Im also running TS 5.4 on Amd geode with ./build --kernel UP with no
> problems.
> Are you sure its related to Non Pae kernel?
>
>
>
>
> --
> View this message in context: http://thinstation.4464.n7.nabble.com/Thinstation-on-Old-Hardware-tp25627p25628.html
> Sent from the thinstation-general mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> Don't Limit Your Business. Reach for the Cloud.
> GigeNET's Cloud Solutions provide you with the tools and support that
> you need to offload your IT needs and focus on growing your business.
> Configured For All Businesses. Start Your Cloud Today.
> https://www.gigenetcloud.com/
> _______________________________________________
> Thinstation-general mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/thinstation-general


------------------------------------------------------------------------------
Don't Limit Your Business. Reach for the Cloud.
GigeNET's Cloud Solutions provide you with the tools and support that
you need to offload your IT needs and focus on growing your business.
Configured For All Businesses. Start Your Cloud Today.
https://www.gigenetcloud.com/
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general