question about WAIT_FOR_LINK=true

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

question about WAIT_FOR_LINK=true

trentasis
Hi,

what is this parameter WAIT_FOR_LINK=true ? I'm not sure in what situations is applied and why...
Thanks

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: question about WAIT_FOR_LINK=true

thinstation-general mailing list
Sometimes people renegotiate their link after system configuration, but it does not finish before the client starts, which causes an ugly error. WAIT_FOR_LINK=true will cause the system to spin for a bit while waiting for the network to fully initialize, then continue onto the user session. This is presently the default for 5.5


On Friday, July 7, 2017 11:27 AM, Trenta sis <[hidden email]> wrote:


Hi,

what is this parameter WAIT_FOR_LINK=true ? I'm not sure in what situations is applied and why...
Thanks
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: question about WAIT_FOR_LINK=true

Blindauer Emmanuel-2
In reply to this post by trentasis
When activating the network interface, there is a delay for the network
driver to know is the link is up (layer1 from OSI). This variable allow
the driver to wait to be sure for the state of the value reported for link.
For example, if the remote switch is a cisco, and fastport isn't
enabled, the link isn't set to active, in a delay up to 15s, to detect
loop. This allow the PC to wait this delay before starting the dhcp
process. Otherwhise, the dialog start immediately, and these is no
answer, so no IP etc....

Emmanuel Blindauer

On 07/07/2017 20:26, Trenta sis wrote:

> Hi,
>
> what is this parameter WAIT_FOR_LINK=true ? I'm not sure in what
> situations is applied and why...
> Thanks
>
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>
>
>
> _______________________________________________
> Thinstation-general mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/thinstation-general
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: question about WAIT_FOR_LINK=true

trentasis
Ok, this means that always wait 12 second (default value) or onlye on worst case? I have detected from 5.4 to 5.5 slower boot...

Thanks

2017-07-07 20:45 GMT+02:00 Blindauer Emmanuel <[hidden email]>:
When activating the network interface, there is a delay for the network driver to know is the link is up (layer1 from OSI). This variable allow the driver to wait to be sure for the state of the value reported for link.
For example, if the remote switch is a cisco, and fastport isn't enabled, the link isn't set to active, in a delay up to 15s, to detect loop. This allow the PC to wait this delay before starting the dhcp process. Otherwhise, the dialog start immediately, and these is no answer, so no IP etc....

Emmanuel Blindauer


On 07/07/2017 20:26, Trenta sis wrote:
Hi,

what is this parameter WAIT_FOR_LINK=true ? I'm not sure in what
situations is applied and why...
Thanks


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot



_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: question about WAIT_FOR_LINK=true

thinstation-general mailing list
It's a timeout, so at the most, only wait that long, then produce some kind of error.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Reply | Threaded
Open this post in threaded view
|

Re: question about WAIT_FOR_LINK=true

trentasis
Thanks!


2017-07-07 21:11 GMT+02:00 Don Cupp via Thinstation-general <[hidden email]>:
It's a timeout, so at the most, only wait that long, then produce some kind of error.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general