thinstation 5.5 NTP seems not to be executed on boot

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

thinstation 5.5 NTP seems not to be executed on boot

fly66
Hi all,
when I boot my thinclient I have this situation:

251TC001:~# date
ven nov 18 12:34:12 CET 2016

251TC001:~# hwclock
ven 18 nov 2016 12:34:18 CET  0.000000 seconds

They are both syncronized but wrong. So I execute:

251TC001:~# ntpdate it.pool.ntp.org
18 Nov 11:48:42 ntpdate[3531]: step time server 37.247.53.178 offset -2914.909950 sec

With this result:

251TC001:~# date
ven nov 18 11:48:53 CET 2016
251TC001:~# hwclock
ven 18 nov 2016 12:37:33 CET  0.000000 seconds

the command date displays date and time correctly, hwclock doesn't.

After a reboot the date command displays a wrong time again.

Package ntp is enabled in build.conf and option NET_TIME_SERVER=it.pool.ntp.org is setted in thinstation.conf.buildtime. I use these two config files only.

Thanks,
Flavio
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: thinstation 5.5 NTP seems not to be executed on boot

fly66
It seems that after some time that the thin client is on, the synchronization between ntp server, operating system and pc clock takes place. I didn't change anything and now both timers display the correct date and time.

I think that thinstation doesn't syncronize the time with the ntp server on boot but later (maybe one hour).

Is it right?

Thanks,
Flavio
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: thinstation 5.5 NTP seems not to be executed on boot

Don Cupp
Yes. You have it now.


Sent from Yahoo Mail for iPhone

On Friday, November 18, 2016, 4:15 AM, fly66 <[hidden email]> wrote:

It seems that after some time that the thin client is on, the synchronization
between ntp server, operating system and pc clock takes place. I didn't
change anything and now both timers display the correct date and time.

I think that thinstation doesn't syncronize the time with the ntp server on
boot but later (maybe one hour).

Is it right?

Thanks,
Flavio



--
View this message in context: http://thinstation.4464.n7.nabble.com/thinstation-5-5-NTP-seems-not-to-be-executed-on-boot-tp26339p26341.html

Sent from the thinstation-general mailing list archive at Nabble.com.

------------------------------------------------------------------------------
_______________________________________________
Thinstation-general mailing list
<a shape="rect" ymailto="mailto:Thinstation-general@lists.sourceforge.net" href="javascript:return">Thinstation-general@...
https://lists.sourceforge.net/lists/listinfo/thinstation-general

------------------------------------------------------------------------------

_______________________________________________
Thinstation-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/thinstation-general
Loading...